Pushpay Mobile App payment issues
Incident Report for Pushpay
Resolved
This incident has been resolved.
Posted about 2 years ago. Mar 13, 2016 - 11:18 PDT
Investigating
We have identified an issue where Pushpay Mobile App payments were not working. Engineers have identified the problem and are monitoring the situation.

Alternatively, users can make payments by visiting https://pushpay.com/login
Posted about 2 years ago. Mar 13, 2016 - 10:54 PDT