iOS payments are not completing
Incident Report for Pushpay
Resolved
The issue has now been resolved
Posted about 2 years ago. Mar 01, 2016 - 13:59 PST
Investigating
We are investigating an issue where iOS payments are not completing. Alternatively, users can make payments by visiting https://pushpay.com/login
Posted about 2 years ago. Mar 01, 2016 - 13:21 PST