Payment failures using Pushpay
Incident Report for Pushpay
Resolved
This incident has been resolved.
Posted almost 3 years ago. Jun 12, 2015 - 04:45 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted almost 3 years ago. Jun 12, 2015 - 04:19 PDT
Identified
The cause of the fault has been identified and engineers are working to resolve the problem.
Posted almost 3 years ago. Jun 12, 2015 - 03:46 PDT
Investigating
We are currently experiencing payment issues using the Pushpay platform. Engineers are investigating the problem and hope to have an update shortly.
Posted almost 3 years ago. Jun 12, 2015 - 03:35 PDT