Credit card payment failures using Pushpay
Incident Report for Pushpay
Resolved
Service has been restored with no failed payments reported for the past 60 minutes.
Posted about 2 years ago. Apr 07, 2016 - 00:10 PDT
Identified
We are still observing periods of failed payments. The team are investigating the issue.
Posted about 2 years ago. Apr 06, 2016 - 22:41 PDT
Monitoring
Card processing has returned to normal with no payment errors seen for the past 30 minutes. Engineers will continue to monitor the situation.
Posted about 2 years ago. Apr 06, 2016 - 21:46 PDT
Investigating
We are currently experiencing credit card payment issues. Engineers are investigating the problem and hope to have it resolved shortly.
Posted about 2 years ago. Apr 06, 2016 - 20:44 PDT