Payment processing interruption for some merchants
Incident Report for Pushpay
Resolved
This incident has been resolved.
Posted almost 3 years ago. Jul 16, 2015 - 13:54 PDT
Investigating
One of our processing partners is currently experiencing unplanned service interruptions. This is being investigated by engineers and we are monitoring the situation closely.
Posted almost 3 years ago. Jul 16, 2015 - 12:58 PDT