Credit card payment failures using Pushpay
Incident Report for Pushpay
Resolved
All payments are processing normally.
Posted over 2 years ago. Jan 29, 2016 - 16:29 PST
Monitoring
Our processing provider has stabilized the situation. We are still seeing intermittent failures. Our Engineers are monitoring the situation.
Posted over 2 years ago. Jan 29, 2016 - 14:26 PST
Investigating
We are currently experiencing credit card payment issues. Engineers are investigating the problem and hope to have it resolved shortly.
Posted over 2 years ago. Jan 29, 2016 - 12:19 PST