Problem with delivering emails
Incident Report for Pushpay
Resolved
Indications are that all email delivery services are now back to normal.
Posted over 2 years ago. Jul 29, 2015 - 17:15 PDT
Identified
Email delivery is slow due to an issue with our mail delivery provider. We are currently monitoring the situation and will update once the issue is resolved.
Posted over 2 years ago. Jul 29, 2015 - 16:54 PDT