Final testing following scheduled maintenance
Incident Report for Pushpay
Resolved
We've finished testing. Things are back to normal. Thanks for your patience.
Posted Nov 12, 2014 - 00:32 PST
Monitoring
We're just completing final testing following our scheduled maintenance. We will have an update at 0:30PST.
Posted Nov 12, 2014 - 00:01 PST