Credit card payment failures using Pushpay
Incident Report for Pushpay
Resolved
This incident has been resolved. No failed payments have been reported for the past 3 hours.
Posted over 2 years ago. Jun 01, 2016 - 20:00 PDT
Monitoring
Card processing has returned to normal with no payment errors seen for the past 20 minutes. Engineers will continue to monitor the situation.
Posted over 2 years ago. Jun 01, 2016 - 16:51 PDT
Investigating
We are currently experiencing credit card payment issues. Engineers are investigating the problem and hope to have it resolved shortly.
Posted over 2 years ago. Jun 01, 2016 - 16:39 PDT