Slow response times
Incident Report for Pushpay
Resolved
We have identified the issue and have implemented a change to restore performance. We are monitoring the situation at this point.
Posted Jan 11, 2015 - 17:49 PST
Investigating
We are investigating an issue where the pushpay.com website is unresponsive or slow
Posted Jan 11, 2015 - 17:21 PST