Credit card payment failures using Pushpay
Incident Report for Pushpay
Resolved
Service has been restored with no failed payments reported for the past 2 and a half hours.
Posted over 2 years ago. Apr 07, 2016 - 10:41 PDT
Monitoring
The processing issue with our downstream partner has been identified and a fix is in place. Payments are now processing normally. Our engineers will continue to monitor the situation.
Posted over 2 years ago. Apr 07, 2016 - 08:34 PDT
Identified
We are continuing to experience intermittent card payment issues causing some payments to fail. Engineers are continuing to work with our downstream partners to resolve the issue.
Posted over 2 years ago. Apr 07, 2016 - 00:31 PDT