Issues processing payments for merchants using Beanstream
Incident Report for Pushpay
Resolved
The issue has now been resolved and the merchants affected are able to receive payments again.
Posted Oct 30, 2014 - 03:41 PDT
Identified
We are currently experiencing issues with processing payments for merchants using Beanstream
Posted Oct 30, 2014 - 03:37 PDT