Payment failures using Pushpay
Incident Report for Pushpay
Resolved
The issue has been resolved, all payments are now processing correctly. Any card payments attempted during the outage will have failed and Pushpay users will not have been charged. Our apologies for any inconvenience caused.
Posted Mar 26, 2015 - 19:36 PDT
Identified
The cause of the fault has been identified and engineers are working to resolve the problem. Normal service will be restored shortly.
Posted Mar 26, 2015 - 19:20 PDT
Investigating
We are currently experiencing payment issues using the Pushpay platform. Engineers are investigating the problem and hope to have it resolved shortly.
Posted Mar 26, 2015 - 19:08 PDT