SMS Delivery issues
Incident Report for Pushpay
Resolved
We have now resolved the issue with SMS delivery.
Posted Dec 02, 2014 - 21:44 PST
Identified
We have identified the cause of the problem and are working to have a fix made available within the hour.
Posted Dec 02, 2014 - 21:11 PST
Investigating
We are currently investigating issues with delivering SMS messages
Posted Dec 02, 2014 - 19:48 PST