Card payment failures using Pushpay
Incident Report for Pushpay
Resolved
This incident has been resolved. No failed payments have been reported in the last 3 hours.
Posted over 1 year ago. Jul 14, 2017 - 01:19 PDT
Monitoring
Engineers have identified the root cause and we're seeing successful payment rates return to normal.
Posted over 1 year ago. Jul 13, 2017 - 22:36 PDT
Investigating
We are currently experiencing issues with processing card payments
Posted over 1 year ago. Jul 13, 2017 - 21:18 PDT