Issues processing payments for australian merchants using Pin Payments
Incident Report for Pushpay
Resolved
We've worked with Pin Payments and resolved this issue. Merchants using Pin Payments can now receive payments again.
Posted Oct 20, 2014 - 15:49 PDT
Investigating
We're currently investigating issues processing payments for Australian merchants who use Pin Payments as their gateway.
Posted Oct 20, 2014 - 13:25 PDT