ACH Payment processing interruptions
Incident Report for Pushpay
Resolved
This incident has been resolved.
Posted about 3 years ago. Nov 12, 2015 - 18:05 PST
Investigating
Our ACH processing partner is currently experiencing intermittent service interruptions. This is being investigated by engineers and we are monitoring the situation closely.
Posted about 3 years ago. Nov 12, 2015 - 15:46 PST