Card payment failures using Pushpay
Incident Report for Pushpay
Resolved
This incident has been resolved. No failed payments have been reported for in the last 90 minutes.
Posted about 2 years ago. Nov 11, 2016 - 21:44 PST
Monitoring
Engineers have identified the root cause and we're seeing successful payment rates return to normal.
Posted about 2 years ago. Nov 11, 2016 - 20:10 PST
Investigating
We are currently experiencing intermittent card payment issues. Engineers are investigating the problem and hope to have it resolved shortly.
Posted about 2 years ago. Nov 11, 2016 - 19:15 PST