Email Delivery Issues
Incident Report for Pushpay
Resolved
Emails from Pushpay are once again free flowing.
Posted Oct 17, 2014 - 20:50 PDT
Investigating
We are noticing very slow delivery times for some emails from Pushpay. An investigation is ongoing. If you are expecting an email from Pushpay please hold tight.
Posted Oct 17, 2014 - 20:30 PDT