ACH Payment processing interruptions
Incident Report for Pushpay
Resolved
This incident has been resolved.
Posted about 3 years ago. Nov 18, 2015 - 16:39 PST
Monitoring
Our ACH processing partner has restored service. We are continuing to monitor the situation closely.
Posted about 3 years ago. Nov 18, 2015 - 16:00 PST
Investigating
Our ACH processing partner is currently experiencing a service interruption. This is being investigated by engineers and we are monitoring the situation closely.
Posted about 3 years ago. Nov 18, 2015 - 13:23 PST