Transaction Reporting Delays

Incident Report for Pushpay

Resolved

This issue has been fully resolved. The fix is now active across all systems, all backlogged transaction data has finished processing, and report updates have returned to normal operating speeds. Payment processing was not impacted during this event.
Posted Sep 06, 2026 - 10:21 PDT

Monitoring

We have identified and deployed a fix for the issue causing intermittent delays in transaction visibility on reports. Report updates may continue to experience minor delays while backlogged data processes and the fix fully rolls out. We are actively monitoring the situation and will update when recovery is complete.

Payment processing is not impacted.
Posted Sep 06, 2026 - 09:48 PDT
This incident affected: Pushpay Giving (Customer Admin Portal).