Issue Adding New Card Payment Methods
Incident Report for Pushpay
Resolved
From 7:47 - 8:10 am PDT, one of our downstream partners experienced an issue with tokenizing new credit/debit cards, which prevented donors from adding new credit/debit cards in Pushpay. Existing card and new or existing ACH payment methods were able to be used by donors during this time. We appreciate your understanding while we worked closely with our partner to quickly resolve the issue.
Posted Apr 17, 2020 - 08:00 PDT