Slow response times in giving experiences
Incident Report for Pushpay
Resolved
We have fully resolved the issue that was causing intermittent platform delays. Thank you for your patience as our team worked to resolve the issue.
Posted Mar 15, 2020 - 12:32 PDT
Monitoring
Our Engineers have been actively troubleshooting an issue that resulted in some users encountering intermittent slow load times or timeout errors. We have since increased our server capacity to manage and level out site reliability and are now seeing user experience return to normal. Our team is actively monitoring the situation and will update this page with any new information. If you have any questions, please don’t hesitate to reach out to our team at care@pushpay.com.
Posted Mar 15, 2020 - 09:56 PDT
This incident affected: Pushpay Giving (Giving Experiences).