Email Delivery Delays
Incident Report for Pushpay
Resolved
We have confirmed that email delivery has been restored. We appreciate your patience while we worked with our partner to resolve this issue.
Posted Jan 17, 2020 - 12:18 PST
Monitoring
We are beginning to see delivery recover - new emails are delivering immediately and queued emails are being processed. Our engineers are continuing to monitor.
Posted Jan 17, 2020 - 11:14 PST
Investigating
We have identified an issue with emails not being delivered in a timely manner. Our engineers are urgently investigating and working with downstream partners to resolve the issue. We apologize for any inconvenience this may cause. We will provide updates here, as we are able.
Posted Jan 17, 2020 - 09:47 PST
This incident affected: Pushpay Giving (Giving Experiences).