Brother Printing Impacted in Latest Check-in App Update

Incident Report for Pushpay

Resolved

This issue has now been resolved and Check-in is operating normally. Thank you for your patience.
Posted Sep 13, 2026 - 08:14 PDT

Monitoring

A fix has been applied, and ability to choose Brother Printers as an option have returned to normal across Check-in. We are continuing to monitor error rates to ensure full stability before marking this fully resolved. Users may need to close the app and reopen it to refresh and receive the fix.
Posted Sep 13, 2026 - 07:01 PDT

Identified

We are currently investigating reports of Brother Printers not showing up as an available printing option in the latest Check-in app update. Our engineering team is actively investigating, and we will provide our next update within 30 minutes. While this is being worked on, we encourage users to NOT update the Check-in app.
Posted Sep 13, 2026 - 06:40 PDT
This incident affected: Pushpay ChMS (Checkin).