Apple Pay Payment Issues

Incident Report for Pushpay

Resolved

We have confirmed the issues affecting Apple Pay have been resolved. Payments / donations via Apple Pay are now processing as expected.
Posted Oct 23, 2024 - 14:02 PDT

Investigating

We are aware that some users are experiencing issues with Apple Pay payments. Our team is investigating.
Posted Oct 23, 2024 - 12:47 PDT
This incident affected: Pushpay Giving (Giving Experiences).