Problems processing Discover card payments
Incident Report for Pushpay
Resolved
Our processing partner has deployed a fix which has resolved this issue.
Posted over 2 years ago. Apr 26, 2016 - 01:16 PDT
Identified
Our engineers have escalated this to our processing partner who continue to investigate the issue.
Posted over 2 years ago. Apr 25, 2016 - 21:10 PDT
Investigating
Our engineers are currently investigating problems processing Discover cards.
Posted over 2 years ago. Apr 25, 2016 - 18:57 PDT