Access to Customer Admin Portal unavailable
Incident Report for Pushpay
Resolved
Sign-in functionality is fully restored for Customer administrators.
We appreciate your patience while we worked with our authentication partner to resolve this issue.
Posted Dec 19, 2019 - 11:59 PST
Monitoring
Our authentication partner has identified the problem and has made fixes which is returning response times to normal.

Customer admin logins should begin working again, and our team continues to monitor the situation.
Posted Dec 19, 2019 - 11:25 PST
Identified
One of our authentication partners is experiencing extended response times, which is preventing Customer administrators from logging into Pushpay.com. This does not affect donors or donations.

We apologize for any inconvenience this will cause, and will update this incident when the issue is resolved. Thank you for your understanding.
Posted Dec 19, 2019 - 10:25 PST
This incident affected: Pushpay Giving (Giving Experiences).