Check Deposit Unavailable
Incident Report for Pushpay
Resolved
We have confirmed that service has been restored.
We thank you for your patience as we worked with our partner to have this issue resolved.
Posted Apr 06, 2021 - 15:05 PDT
Monitoring
Our Check Deposit (ProfitStars) partner has resolved the issue and we are now monitoring the situation.
Posted Apr 06, 2021 - 11:59 PDT
Identified
Our Check Deposit partner (ProfitStars) is currently experiencing issues. Engineers are investigating the problem. In the meantime, Check Deposit will be unavailable. We apologize for any inconvenience this will cause, and will update this incident when the issue is resolved. Thank you for your understanding.
Posted Apr 06, 2021 - 11:28 PDT
This incident affected: Pushpay Giving (Customer Admin Portal, Giving Experiences) and Church Community Builder (Web Portal).