Issue Adding New Card Payment Methods
Incident Report for Pushpay
Resolved
Our downstream partner has fully resolved this issue. Donors should now be able to add new credit/debit cards within Pushpay. Thank you for your patience as we worked with our partner to resolve the issue.
Posted Jun 08, 2021 - 04:20 PDT
Monitoring
Our downstream partner has deployed a fix for this issue. Our team is continuing to monitor the situation and we will provide an update on full resolution as soon as possible.
Posted Jun 08, 2021 - 04:08 PDT
Identified
One of our downstream partners is experiencing an issue with tokenizing new credit/debit cards, which is preventing donors from adding new credit/debit cards in Pushpay. Existing card and new or existing ACH payment methods are able to be used by donors during this time. We appreciate your understanding while we work closely with our partner to quickly resolve the issue.
Posted Jun 08, 2021 - 03:41 PDT
This incident affected: Pushpay Giving (API, Giving Experiences).