Emergency Maintenance required
Incident Report for Pushpay
Resolved
Patch has been applied - all systems back to normal.
Posted Nov 11, 2014 - 13:57 PST
Identified
Due to an announcement from Microsoft we're going to have a quick production outage while we patch our systems against a known security vulnerability (Schannel - MS14-066).
Posted Nov 11, 2014 - 13:28 PST