YouTube Experiencing Video Playback Issues
Incident Report for Pushpay
Resolved
YouTube has now resolved the video playback issues.
Posted Nov 11, 2020 - 19:03 PST
Identified
The YouTube platform is experiencing global playback issues. Because of this, app users may experience temporary issues viewing YouTube videos in our Pushpay mobile apps.

We will update our status page when we have confirmed YouTube has fully resolved the issue.
Posted Nov 11, 2020 - 16:50 PST
This incident affected: Mobile Apps (Mobile Apps).