SMS issues on 77977 for Sprint customers
Incident Report for Pushpay
Resolved
Service has now been fully restored.
Posted Mar 21, 2020 - 13:59 PDT
Identified
The issue has been identified with our upstream message partner, and a fix has been implemented. There a large number of queued messages which must be processed before full service is restored. We will provide an update once service is fully restored.
Posted Mar 21, 2020 - 13:36 PDT
Investigating
We are investigating issues with responses to messages sent to 77977 for customers with phones on the Sprint network. We will provide updates here soon.
Posted Mar 21, 2020 - 13:23 PDT
This incident affected: Pushpay Giving (Giving Experiences).