Problem with delivering emails
Incident Report for Pushpay
Resolved
Monitoring has shown that all email delivery services are now back to normal.
Posted Mar 16, 2015 - 02:43 PDT
Monitoring
Email delivery service appears to returning to normal. We are continuing to monitor the situation.
Posted Mar 15, 2015 - 23:13 PDT
Investigating
Email delivery is slow and/or failing intermittently due to an issue with our mail delivery provider. We are currently monitoring the situation and will update once the issue is resolved.
Posted Mar 15, 2015 - 21:18 PDT