Issues with SMS and Email Delivery
Incident Report for Pushpay
Resolved
This incident has been resolved.
Posted almost 3 years ago. Jan 05, 2016 - 21:07 PST
Identified
The issue has been identified and a fix is being implemented.
Posted almost 3 years ago. Jan 05, 2016 - 19:59 PST
Investigating
We are currently investigating issues with delivery of SMS messages and emails. Engineers are working on a resolution.
Posted almost 3 years ago. Jan 05, 2016 - 19:45 PST