Check Deposit unavailable
Incident Report for Pushpay
Resolved
We have confirmed that service has been restored.

We thank you for your patience as we worked with our partner to have this issue resolved.
Posted Dec 17, 2019 - 20:16 PST
Monitoring
Our Check Deposit partner has resolved the issue and we are now monitoring the situation.
Posted Dec 17, 2019 - 19:39 PST
Identified
Our Check Deposit partner is currently experiencing issues. Engineers are investigating the problem. In the meantime, Check Deposit will be unavailable. We apologize for any inconvenience this will cause, and will update this incident when the issue is resolved. Thank you for your understanding.
Posted Dec 17, 2019 - 17:31 PST
This incident affected: Pushpay Web.