AWS Connectivity Issues
Incident Report for Pushpay
Resolved
AWS have resolved the connectivity problem and our platform load times have returned to normal. We appreciate your patience and understanding as we partnered with AWS to resolve this issue.
Posted Aug 31, 2021 - 18:01 PDT
Monitoring
AWS have resolved the connectivity issue and our platform load times have returned to normal. We’ll continue to monitor the situation to ensure full recovery.
Posted Aug 31, 2021 - 16:41 PDT
Update
Our downstream partner, Amazon Web Services (AWS), has identified the cause of the connectivity issues. We are working closely with AWS to resolve the issue and will update this page as soon as we receive more information.
Posted Aug 31, 2021 - 14:36 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 31, 2021 - 14:35 PDT
Identified
Our downstream partner, Amazon Web Services (AWS), is currently experiencing connectivity issues, which is resulting in timeouts and loading issues in some of our systems. We are working with our partner to resolve the issue and will update this page as soon as we receive more information.
Posted Aug 31, 2021 - 11:52 PDT
This incident affected: Pushpay Giving (Customer Admin Portal, API, Giving Experiences) and Mobile Apps (Mobile Application Studio, Mobile Apps).