Investigation Opened: Customer Admin Portal
Incident Report for Pushpay
Resolved
We have received confirmation that the elevated error rates and high latency issue has been resolved and service has been fully restored.
We appreciate your patience while we worked with our partner to resolve this issue.
Posted Mar 30, 2020 - 18:29 PDT
Monitoring
Our cloud provider is beginning to see recovery for the elevated error rates and high latency. We will continue to monitor the issue. Thank you for your patience while we work with our partner.
Posted Mar 30, 2020 - 18:04 PDT
Identified
The issue has been identified with our cloud provider. We have implemented a fix to work around the issue while they stabilize their system. Thank you for your patience while we work with our partner.
Posted Mar 30, 2020 - 17:19 PDT
Investigating
We are investigating intermittent issues with the Customer Admin Portal and App Profile Logins will provide updates here soon.
Posted Mar 30, 2020 - 16:25 PDT
This incident affected: Pushpay Giving (API, Giving Experiences) and Mobile Apps (Mobile Apps).