Pushpay Giving Portal timeouts
Incident Report for Pushpay
Resolved
We have identified and resolved the issue that was causing platform delays. We are continuing to monitor the situation and ensure full restoration. Thank you for your patience as our team worked to resolve the issue.
Posted Feb 16, 2020 - 17:46 PST
Monitoring
We have identified and resolved the root issue that was causing platform delays. We are continuing to monitor the situation and ensure full restoration. Thank you for your patience as our team worked to resolve the issue.
Posted Feb 16, 2020 - 15:24 PST
Identified
We have made an update to our system that has resolved the issue affecting payments. Our team is continuing to fully resolve the issue impacting administrators, and will update this page when we have more information.
Posted Feb 16, 2020 - 10:43 PST
Update
We are continuing to investigate this issue.
Posted Feb 16, 2020 - 10:05 PST
Investigating
We have identified an issue impacting the Pushpay giving solution, including payments and access to the administrative portal, that is causing users to experience slow load times and timeouts. We are urgently investigating and will update this page as we have more information.
Posted Feb 16, 2020 - 10:05 PST
This incident affected: Mobile Apps (Mobile Apps) and Pushpay Giving (Giving Experiences).