ACH payment failures using Pushpay
Incident Report for Pushpay
Resolved
This incident has been resolved. No failed payments have been reported for the past hour.
Posted almost 2 years ago. Sep 10, 2016 - 01:25 PDT
Monitoring
ACH processing has returned to normal with no payment errors seen for the past 10 minutes. Engineers will continue to monitor the situation.
Posted almost 2 years ago. Sep 10, 2016 - 00:45 PDT
Investigating
We are currently experiencing ACH payment issues for US merchants. Engineers are investigating the problem and hope to have it resolved shortly.
Posted almost 2 years ago. Sep 10, 2016 - 00:27 PDT