Web Giving Platform Unavailable
Incident Report for Pushpay
Resolved
This incident has been resolved.
Posted Jun 10, 2019 - 17:55 PDT
Investigating
We have identified and resolved an issue with our web platform, affecting users' ability to contribute through the internet browser payment experience and access our customer portal.

We understand the disruption this may have caused and sincerely apologize for any inconvenience. Our engineers have resolved the issue and will continue to monitor.

This incident took place between 12:24 and 12:36 UTC with the web platform being unavailable for 12 minutes.

You can subscribe to this page for immediate notification of any future issues.
Posted Jun 10, 2019 - 17:53 PDT
This incident affected: Pushpay Giving (Giving Experiences).